Data overlaps when long text database column is joined


From the hive connector and then database table selectors, im joining multiple tables, each has around 50 fields. Join criteria is by id field which is a string of length=18.

Join seems to work if there are no long text fields. We have description field from one of the table which has extremely long text values that overlaps into next row columns.

i have tried all kinds of joins, i get the same result. This was very unexpected.

Is there anyway to solve this error.


does the problem also occur if you only retrieve data including the long text column without joining the table with another table?

Is the datatable specification in KNIME as expected e.g. does it contain the selected columns or are there some columns missing or have an unexpected data type?

Can you please try to execute the join statement in another tool. To do so simply open the outport view of the Joiner node in KNIME, go to the Connection tab and press the Copy to Clipboard button in the lower right corner to copy the SQL statement into the system clipboard.



Hi Tobias,

Issue is not seen when we retrieve the data.

I have checked cached rows in Table Selector Nodes. Everything looks fine.

But, error is seen from cached rows of Database Joiner.

Have run the same query in hive and hadoop, i get the correct data. No errors there.




Hi Spandan,

this is strange since the Joiner node and the Table Selector node use the same way to execute the query and extract the data.

Can you please copy the SQL statment from the Joiner node and paste it into the Database Query node. To avoid the missing place holder error simply write --#table# in the first line and past the copied statement into the second line of the query window.

Could you also please post the join statement or send it via

What happens if you remove all columns in the Join except for the join column and the description column?