Database SQL Executor doesn't execute all code (PostgreSQL)


I’m having trouble with the Database SQL Executor.

In my current flow, I read some data, manipulate it, and write it with the Executor node to my DB. So far, so good. I query some information back, manipulate it some more, and try to feed it back to a different table in my DB. However, this time the execution stays at 0% for > 1 hour (haven’t waited any longer). If I run the query directly in my PostgreSQL server, it executes in under a minute.

I don’t understand how this is possible, and would very much like a solution.

Thank you,

PS: When executing the query, my Antimalware Service Executable goes nuts (40%+ CPU usage, 90%+ disk usage)

Have you tried a small portion of the data first to see if it does work at all.

And then the obvious question does it work if you turn off the anti malware or tame it?

Cutting up the data and allocating more RAM solved the issue. The calculations for the query didn;t fit in the allocated RAM, and so it’s started using the HDD and slowed down the process (and triggering Antimalware).


1 Like

If you never tried then I would suggest you to Uninstall any problematic third-party programs. This will fix antimalware service execitable error easily.

1 Like