DB Connector doesn't work after migration

Hey Knime - experts!

We’ve just recently upgraded our version of KNIME to the currently newest version and to also make good use of the new DB Executors/Readers we migrated our DB Connectors.
Unfortunately after migrating they won’t connect to the DB anymore.

By using the Node “DB Connector” I get the error: Login failed for user : …
By using the Node “Microsoft SQL Server Connector” I get the error: Execute failed. The port number sqlserver… is not valid.

We’ve checked PW and Username for Login and they are fine, the Hostname is also correct. We didn’t use a Port in the Legacy Connectors and just had the Hostname basically.

Does anyone have an idea what we are doing wrong?
Nothing was changed in the nodes besides the PW after migrating so I am not quite sure if I need to add something somewhere…

Thanks in advance,
Chaosprinzip

Little addition:

One of our Connections is working now - the other one still gives Login failed for user…
I’m using exactly the same parameters as for the other connection (The DB is on another machine though), besides changing the Hostname of course.
I also tried to directly go to a Database to no avail.

Also: The server with working connection is running on SQL Server 2017 and the one not working on SQL Server 2014
Other than that we can’t see any differences in the servers or rights.

Hello @Chaosprinzip,

what error are you seeing and from which node when trying to connect to SQL Server 2014? Are you using same driver to connect to both DB versions? Which one?

Br,
Ivan

Hello Chaosprinzip,

did you register your own JDBC driver? If so can you please double check the URL template in the driver registration dialog. For the JDBC driver provided by Microsoft it has to look like the following and is preset when you select mssqlserver as Database type:

The template is used to create the connection string by replacing the placeholder such as and with the values you enter in the node dialog. For more details please see the db documentation.

Bye
Tobias

Hey, thanks for the answers.

As far as I know we didn’t register our own drivers.
After the update we are still able to use the legacy Database Connector Node.

This is how the legacy node is set up

The next screenshot shows the working connection to the 2017 Server:

This is the error and the setup of the not working connection to the 2014 server.
(Yesterday I got a different error though, so not sure why the error message has changed)


The legacy connections are still working and Hostname + credentials are definitely right. We have read, execute rights for the server/DB. Anyone got an idea why this happens?

Nevermind the error message I posted it’s still the same error: Login failed
I just had a typo in the hostname this morning

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.