DB Table creator column with double quote Issue

Hi !
Goal: Create a table structure into Snowflake in order to “COPY INTO” data.
Context: To create a table structure the command line is pretty basic but to keep the case sensitive the column names need to be arounded with double quote ".
Problem: I used the node database table creator and it looks perfect, but unfortunately the column names are without " and all my field are defined UPPER CASE in the database.
I tried to name the column name using " around it but then the node add " around the column name and then the command sent to the database is wrong: column name are "“Column1"” varchar(255)… double double quote. I tried simple quote, renaming column names afterward, etc… but nothing.

Do you have an idea to resolve my issue?

Thank you !

Hi Yoannleny,

Try using the new DB Connector and DB Table Creator nodes that are available in KNIME Labs / DB. They are part of a new framework (that is in development) and support quoting for the column names.

Hope it helps.
Best,
Daria

1 Like

Hi Daria,

This is great ! It’s working.
This is a good one for people using database like snowflake.

Thank you

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.