Deep learning and keras errors

I am trying to use keras node in KNIME Analytics.

But I got following error when I use keras network learner node.

ERROR Keras Network Learner 3:13 ‘DataFrame’ object has no attribute ‘convert_objects’
Traceback (most recent call last):
File “”, line 5, in
File “F:\Program Files\KNIME\plugins\org.knime.dl.python_4.2.0.v202007071214\py\”, line 97, in get_layer_data_specs_as_data_frames
input_specs = extractor.input_specs_to_data_frame()
File “F:\Program Files\KNIME\plugins\org.knime.dl.python_4.2.0.v202007071214\py\”, line 57, in input_specs_to_data_frame
return self.__layer_data_specs_to_data_frame(self._network_spec.input_specs)
File “F:\Program Files\KNIME\plugins\org.knime.dl.python_4.2.0.v202007071214\py\”, line 88, in __layer_data_specs_to_data_frame
specs_with_numeric_types = specs.convert_objects(convert_numeric=True)
File “C:\ProgramData\Anaconda3\lib\site-packages\pandas\core\”, line 5130, in getattr
return object.getattribute(self, name)
AttributeError: ‘DataFrame’ object has no attribute ‘convert_objects’

Even a workflow that worked fine before, now gives the same error.
Also the same error occurs when I tried to DL python network learner node.

The same thing is happening on other computers.

I think there is a change on the KNIME platform or nodes related with deep learning,
how do I use the deep learning nodes?

Hi @zhddhkdn,

What version of the pandas package are you using in your Python environment(s)? KNIME is still relying on version 0.23. Newer versions introduced breaking changes which is why they do not yet work with KNIME.
We are aware of the fact that pandas v0.23 is quite dated by now and are going to upgrade our Python and deep learning integrations to support newer versions as soon as possible.

For the time being, could you try to downgrade pandas to v0.23? This can either be done via the Anaconda Prompt or Anaconda Navigator, or you can let KNIME automatically create a new suitable Python environment for you (please see here to learn how this can be done).




I downgraded pandas packages as you said.

All of nodes related with deep learning works well after downgrading the pandas packages.

Thank you,



I want to ask again.
I solved the problem based on your opinion.

However, when I reuse that workflow on another computer,
new error occurs as follows.

ERROR Keras Network Learner 3:13 Execute failed: (“NullPointerException”): null

I don’t know what this error is.
I got same error with my computer but after downgrading pandas packages, this error occurs newly.

Could you help me one more time?

Hi @zhddhkdn,

Sure. Could you please post your knime.log file here? The file may contain additional information about the error. You can open it by clicking View > Open KNIME log inside KNIME Analytics Platform.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.