DeepLearning4J doesn't use GPU

Hey,

I have the problem that Knime doesn't use my GPU in the DL4J nodes. I have check the box that says that DL4J should use the GPU and restart Knime, the box is unselected afterwards.

The log file then says:

2017-11-01 18:22:09,184 : INFO  : Worker-1 : DL4JPluginActivator :  :  : CPU backend will be used.
2017-11-01 18:22:09,184 : DEBUG : Worker-1 : DL4JPluginActivator :  :  : org.knime.ext.dl4j.bin.windows.x86_64.cpu_0.8.0.v201703291351 matches org\.knime\.ext\.dl4j\.bin\.[^\.]+\.x86_64\.cpu.*
2017-11-01 18:22:09,184 : DEBUG : Worker-1 : DL4JPluginActivator :  :  : The following backend fragment will be used: org.knime.ext.dl4j.bin.windows.x86_64.cpu_0.8.0.v201703291351
 

I have a Geforce GTX 1080 from ASUS and Cuda v8.0.44 installed.

KNIME Version 3.4.1

KNIME Deeplearning4J Integreation 3.4.1.v201709070951

KNIME Image Processing - Deeplearning4J Integreation 1.1.1.v201707101450

Does anyone have any hints how to resolve that issue?

When will Knime support Cuda v9?

 

Regards

 

Hey,

sorry for the inconvenience.

There seems to be a little bug in the preference page. Could you just try selecting it again? I'm not 100% sure how to reproduce this. Maybe you have to hit the Apply button in the settings before hitting OK. We'll look into it.

Cuda 9 is currently not supported by DL4J and I unfortunately don't know any timeline when they plan to support it.

Cheers

David

 

I played a bit with the checkboxes and "Apply"/"OK" buttons.

If you want to enable the GPU and enable the logging too, it doesn't work. No matter in which order you press the buttons.

Enabling the GPU without logging works fine.

 

Maybe you can report that issue.

Thank you very much for your testing effort. I'll file an issue and have a look.