Does DB connector not support length 1 password?

My mysql database’s password is just a character “1”. However when input it in a DB connector, it keeps saying “please input a valid password”.

And leagacy mysql connector is ok.

Hi there @kila,

welcome to KNIME Community!

interesting. Are you using DB Connector or MySQL Connector from new database framework? Or both and both doesn’t work?

Br,
Ivan

I reproduced the behaviour that you described with DbConnectorNode.
You can apply this workaround:

  • write a fake password in password field and substitute password with your password in flow variable tab
    or
  • create credentials as workflow configuration and select this authenication mode in your DbConnector Node
2 Likes

Hello kila,
unfortunately this is a problem with the authentication component itself so it affects all nodes that use this component. I have created a ticket and it will be fixed with the next bug fix release of KNIME.

As a workaround you can use the Credential Configuration node to set the single character password and then select the created credential in the DB Connector node or any other node with the authentication component as described by pigreco.
However setting the password directly via the flow variable tab of the DB Connector node won’t work since this is the encrypted password.
Bye
Tobias

3 Likes

Hi @tobias.koetter what do you think about constant secretKey used by Authentication component to store password?
I think this is a strange choice. secretKey is public domain information.
So this is not a real encryption. Are you agree with me?

The password is not stored as a plain string in the settings model but encrypted using the key. So if you wanted to set it via flow variable you would need to decrypt your password using the same mechanism and key as the component does.
One of the problems with open source is that you can not hide something in the code. But I agree that we should have used a more subtle name for the constant. This is also why we do not recommend to store passwords in the workflow but rather use the credentials e.g. via the Credential Configuration node.

2 Likes

Hello kila,
yesterday we release version 4.1.3 of the KNIME Analytics Platform that fixes the problem with the single character password.
Bye
Tobias

4 Likes