Driver Class not found in Batch Mode

I’m sure I’m missing something obvious, but this has me stumped. I have a workflow connecting to a Microsoft SQL server using integrated security. When running the workflow through the client, everything works. However, when trying to run the workflow in Windows through batch mode, I get the following error.

ERROR KNIME-Worker-3 Node Execute failed: Could not create connection to database: Could not find driver class:
INFO main BatchExecutor Workflow execution done Finished in 4 secs (4564ms)
INFO main BatchExecutor ========= Workflow did not execute sucessfully ============

I’m not sure why the driver would be available in the desktop client, but not when run through batch mode. I have the sqljdbc driver registered in preferences. Does anyone know what I’m missing? Thanks again for your help!

batch command:
“C:\Program Files\KNIME\knime.exe” -consoleLog -noexit -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION -workflowDir=“C:\Users\tabram\knime-workspace\Audit Trail 1” -nosave -reset

Yeah, it was something obvious that I missed. I’m not sure why it worked in the agent, but not the batch run, but I hadn’t installed the extension yet:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.