Early bug in KNIME 2.6.0


Many thanks for the release of KNIME 2.6.0 and the lovely new features and enhancements.

I have noticed one bug with the XLS Reader node in that it fails to load XLSX files (the spreadsheets I am trying are very simple, just some text and numbers). This works in KNIME 2.5.4, but not in KNIME 2.6.0, it reports this error;

ERROR XLSReaderNodeDialog java.lang.reflect.InvocationTargetException

ERROR XLSReaderNodeDialog java.lang.reflect.InvocationTargetException.

I have also noticed another bug, but very minor. If you load in the ComplexSAR workflow from the KNIME public server under Applications and run it to completion, and then save it first. If you then shut the workflow down, and then reopen it, the save icon is available and when you go to reshut it, it asks to save changes, even though no changes have been made. It doesnt affect the operation of the workflow however.


In terms of some new additions, and improvements there are some really impressive ones..

Many thanks for the big improvements with the aggregation nodes. The very quick implementation of the Geometric Mean and Geometric Standard Deviation in the GroupBy node, and being able to select all aggregation columns by numerical/non-numerical/all with a right click. Someone has made me very happy!!, this will save alot of time, especially the Geometric St.Dev. The Groupby node by column aggregation (column aggregator) is another great addition of merging multiple datasets together. Someone needs a big pat on the back for these changes.

Thanks for the quick implementation of dynamic column handling in the (column) splitter node, this used to be a real problem when new columns were introduced.

And the great implementation of the OpenBabel node now, this now allows such a wide variety of chemical format interconversions. This is much more flexible and useable between users now, especially with OpenBabel being part of the KNIME Update Site. Great!

I am also really happy to see the new Round Double node can round by decimal and by significant figures, this is really useful having both options available, really good! Again, thanks for the quick implementation.


Thanks, there have been some really impactful additions in the new release.



I suspect I will struggle to find many bugs in this version as I notice there were alot of bug fixes in the changelog!

I look forward to trying out all the other new features!

Hm, I just tried some random XLSX files and they all worked fine. Can you send me your file and also the stacktrace from the log file?


Attached is a ZIP file containing the very basic XLSX file which will not load, along with the KNIME log file.

Hi, I've also noticed that the Delegating Loop Start node, currentiteration variable, does not increment on each loop.


I've noticed the same problem and error message.

Hi all,


A minor nit: that in v2.6.0 "hide all node names" does not behave consistently if you move from the top-level of a workflow into a metanode. Remove node names at the top-level then browse into a metanode and the names are back again...

Thanks for reporting this issue; I will open a bug report.

Simon, I found the reason for your problem. Both the XLS plug-in and the Marvin extension are providing the same class and the Eclipse classloader at some point gets confused about this. We ha a similar problem before and it depends on the order in which plug-ins are installed/loaded (among others). I will see, how we can fix it.

Thanks for the update, I remember seeing this problem before with KNIME 2.5.0, and then it went away with further 2.5 updates. As you say, it may be the order of installation which is important, which is why the issue temporarily went away.


Another glitch:

in the new java node (which is long awaited and very promising indeed!) on a mac sometimes the cursor keys do not work, and command-C for copy does never seem to work.

edit: oh weird, closing and re-opening and it started to behave as expected.

Hi Simon,

thank you for noticing, this was mainly a stupid typo. We will fix it with the next update.


dear all,

I am on 2.7.2 and when I try the Book1.xlsx I get the following error

ERROR     XML Reader     Execute failed: org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 1; Content is not allowed in prolog.

Actually, this happen with any XLSX

I've removed marvin, CDK, ... still the same error message.

please help !



p.s. a colleague of mine has 2.7.3 and there there are no problems ... shal I upgrade ?

Hi Luca, 

Can you post such a file here for us to look at? At this point I'm not convinced an update would help (but it wouldn't hurt either).