Empty "Configure (F6)" window on Ubuntu 21.04


I’ve just updated Ubuntu from 20.04 to 21.04. KNIME 4.3.2 seems not to like that:

Config window (F6) and help window present no content.

I’ve tried messing with themes, but to no effect.

In help window there seems to be some text (guessing by mouse pointer), but config window seems blank. It also seems like it’s offset is far to the left, outside left window border.

This may be related to custom windows, because Eclipse’s loading sceens, settings, and other windows are okay.

Data table view of any given node is fine.

I’m running
java -version
openjdk version “1.8.0_292”
OpenJDK Runtime Environment (build 1.8.0_292-8u292-b10-0ubuntu1-b10)
OpenJDK 64-Bit Server VM (build 25.292-b10, mixed mode)

Closing “Configure window” causes such line in logs:

(KNIME:38355): Gtk-WARNING **: 14:16:10.613: Negative content height -5 (allocation 1, extents 3x3) while allocating gadget (node button, owner GtkToggleButton)
Exception in thread “AWT-EventQueue-0” java.lang.IllegalStateException: No node context registered with the current thread
at org.knime.core.node.workflow.NodeContext.removeLastContext(NodeContext.java:281)
at org.knime.workbench.ui.wrapper.WrappedNodeDialog.removeNodeContext(WrappedNodeDialog.java:786)
at org.knime.workbench.ui.wrapper.WrappedNodeDialog.lambda$4(WrappedNodeDialog.java:203)
at org.knime.core.node.util.ViewUtils$2.run(ViewUtils.java:155)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:758)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:728)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

No other suspicious entries were found.

Any help is greatly appreciated, as I may have to revert my OS to previous version.

update: on KNIME 4.1.3 help window works. But config ones are still empty.

Okay, I got it. This happens on Wayland, which is now default graphics server in Ubuntu.

Switching back to XOrg on login screen solved the issue, windows are now displayed properly.

Yay, no OS rollback.

I guess this subject now becomes bug report. Shall I provide more information?

1 Like

Hello @pl_profetes,

and welcome to KNIME Community. Seems like a known issue in “the fractured world of Linux”:


Hi! @ipazin,

Good find, I was not able to google that. I was not aware issue has been present for so long. Since Ubuntu default graphics server is changed I expect more users to look for help. And maybe even someone manages to fix that?

Oh, the Linux world…

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.