Empty preview page

When using reporting function the preview page always remains empty, even if I add only simple text on the layout page. I have seen a few similar comments from other users but without a proper solution. Thanks for any comment or advise in advance. Kind regards

stefan

Thanks for reporting this issue. We will look into it.

Dear Gabriel,

I just would like to add that I am using KNIME version 2.10.3, windows 64-bit version.

Even very simple reports such as

<B>Report</B> (inserted in the layout page)

would not be displayed on the preview page and not in pdf reports.

Kind regards

stefan

Hi Stefan, we looked into it and appears to be an Eclipse/BIRT problem with Windows and IE11, see the bug for details, recommending to add two additional JVM properties to the eclipse.ini/knime.ini file which unfortunately did works for us. Maybe worse giving it a try?

-Dorg.eclipse.swt.browser.DefaultType=ie
-Dorg.eclipse.swt.browser.IEVersion=7000

Hi Gabriel,

thanks for the support. Using the following lines in the knime.ini worked for me:

-Dorg.eclipse.swt.browser.DefaultType=ie
-Dorg.eclipse.swt.browser.IEVersion=9999

In addition, however, I had to change the windows registry key:

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeaturControl\FEATURE_BROWSER_EMULATION

knime.exe               REGDWORD         0x0000270f(9999).

What is still strange is that images and html format codes are not translated. In the following example I tried to insert the header "Report" in bold letter and an image from an RView node using the reporting node "Image to report".

The output in the report is the following:

<B>LMR report</B>

89 50 4E 47 0D 0A 1A 0A ...

In addition a banner "Created by Knime Report Design...." is displayed.

Probably something with my settings is wrong but I could not figure out the problem.

Kind regards

Stefan

Hi Gabriel,

I also solved the other issue mentioned previosly. In the layout page the content of the text has to be set from "Auto" to "HTML". Images need to be inserted via Menu "Report Items" and then select dynamic images.

stefan

Wonderful that also worked for me with the additional changes in the regedit.

Just to confirm, you can also use 10001 to be complaint to IE10.