Empty Table Switch's inactive port breaks loop

Hi there,

I’m encountering an error which I can’t wrap my head around.
I’ve got a workflow (“subworkflow_1”) that uses an empty table switch to basically skip the cell splitter node since it can’t ignore empty tables and thus stops my workflow.
This works just fine as a stand-alone but it breaks a loop that happens in another workflow (“main_workflow”) which I use to loop through several subworkflows, all very similar to “subworkflow_1”.

Console: ERROR Loop End 0:125 Active Scope End node in inactive branch not allowed.
KNIME version: 4.4.2 (compatibility, might change soon but that’s not up to me)
workflow sharing is difficult due to confidentiality

Is this behavior intended? How could I ensure the loop on my main_workflow continues running (AKA ignores the inactive port of the Empty Table Switch node)?

Thanking you in advance!

Hi have you already tried starting the group loop before the empthy table switch?

Hi Daniel,

Thank you for your reply.
Yes, I had found some similar posts on the forum and tried to include the empty table switch inside the loop, but to no avail.


UPDATE: the issue was completely unrelated to the empty table switch, the configuration of my container output somehow reset. This coincided with the addition of the table switch so I made the false assumption that the error must’ve come from the table switch. Issue is fixed.

Apologies for the confusion and thanks again to Daniel_Weikert for his help!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.