Error during import! CoreException: Could not write File - Potentially due to Icon file type

I have been trying all day to import this file to my Knime. It worked previously, and it currently works on my colleagues computer.
I have tried a different file and it also errors out on import, and seems to be blocked by an icon here too.
Error code:
org.eclipse,core.runtime.CoreException: Could not write file C:\XXXXXXX\Previous Cyc(#146)\icon
Any help here would be incredible.
I am running the latest version of Knime I have tried to update it.

@Shardham welcome to the KNIME forum. Most likely you will have to check your file system and if KNIME would be allowed to write there.

From my perspective it would make sense to store the knime-workspace somewhere separate from the KNIME software.

Thanks for the reply @rfeigel
I have reinstalled Knime and set up the workspace in my user folder.
I can open the below file: Test Google Connection
But when I try open any of our teams new files they get the icon error. Both these files work on my colleagues computer who downloaded them, he uses Mac.
payroll_qa_cycle2_v1.knar.knwf (308.4 KB)
payroll_split_file_v1.knar.knwf (104.8 KB)

Test Google Connection.knar.knwf (265.9 KB)

@Shardham what happened to your workflow is this:

I have removed the fake “icons”

payroll_split_file_v1.knwf (101.0 KB)

payroll_qa_cycle2_v1.knwf (300.6 KB)

KNWF files are just ZIP files - so you could open them, delete the empty icon files and then pack it again.


Thank you champion that works!!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.