Error | Execute workflow in batch mode

Hi there,

I have created a workflow which should be executed in batch mode.
KNIME.exe and the workflow are saved locally.
I run the following command: C:\Users\User123\Desktop\KNIME\01_KNIME_InstallationFiles\knime_4.1.0\knime.exe -consoleLog -nosplash -reset -workflowFile=“C:\Users\User123\Desktop\Files\KNIME\Automation.knwf” -application org.knime.product.KNIME_BATCH_APPLICATION

However, I get an error that says that the file can’t be accessed because another process has blocked parts of the file.

Can some figure out the problem?

Thank you in advance!

Hi @nocokenever -

Have your tried using the -workflowDir option instead, as suggested in this thread?

Hi @ScottF

I tried that and changed the argument. However, I get another Error that says:

ERROR main BatchExecutor Workflow directory ‘C:\Users\uic123\Desktop\Files\KNIME\Automation.knwf’ is not a directory.

Do you have a clue?

you would have to extract your workflow info a folder instead of a knife file. You point to a ‘regular’ workflow (which is a folder ) instead of a zipped knife file.

1 Like

So I changed it to a zip file but the same error occurs. I don’t know where the mistake is.

ERROR main BatchExecutor Workflow directory ‘C:\Users\uic123\Desktop\Files\KNIME\’ is not a directory.

well it should not be a zip file but a folder as the error message mentions. Maybe that would be an idea.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.