Error executing Python Script with KNIME

Hi all, I have installed KNIME version 3.5.1 and Python 2.7.14 (under Ananconda2). When I am trying to execute a Python script in KNIME, I encountered the following error message:

ERROR Python Script (1⇒1) (deprecated) 0:15 Execute failed: Could not start python kernel:
Library google.protobuf is missing, required minimum version is 2.5.0

Any idea how to solve this problem?

Regards,
Jimmy

Hi Jimmy,

According to the error message, you’re trying to use our old Python integration that was deprecated with KNIME version 3.4. I’d recommend using the new Python integration instead. It can be installed via File > Install KNIME Extensions… > KNIME & Extensions > KNIME Python Integration. This blog post explains how to setup the Python environment for the new integration.

If you still want to use the deprecated integration, please open a terminal and execute the following command:

conda install -n py27_knime protobuf

where you replace “py27_knime” with the name of the Python environment you want to use with KNIME.
This installs google.protobuf into your Python environment and should solve the problem.

Marcel

2 Likes