Error executing Workflow

Hi,

I tried running a workflow on my Knime Server but ran into the next problem:

.

Just today I updated my Knime Analytics Platform from 4.1.2 to 4.1.4. My server is running version 4.10.3.

I created the workflow that crashed after the update. I uploaded the WF to my server and tried to run it on the server. I dont understand why it is crashing on the server if, as far as I understand, the version of the server and my knime analytics are compatible.

Any sugestions on how to solve this problem?

Hi @RaulPerez,

Based on the error message, it appears that the workflow was created locally with KNIME Analytics Platform 4.1.4. However, your KNIME Server uses 4.1.2 as executor. This is prevented, since in knime-server.config, you have com.knime.server.executor.reject_future_workflows=true (which is the default).

You have two options to make this work: Either update you executor, or set com.knime.server.executor.reject_future_workflows=false

Cheers,
Roland

Hi @RolandBurger

Thanks for the advice, let me reach with my IT team so that they can help me with the changes in the server.