error from the substructure counter node

Hi folks,

after upgrading to 2.9 I get a strange behaviour from the substructure counter node. it's unusual because it does not seem to be consistent i.e. not every time I run the node with the same smarts and molecules I get the error. I am pasting below the text that I get in the shell (I am running linux on a 64 bit machine by the way)

I am also attaching a workflow that I used to reproduce this error: I had to use the loop in order to get the error because it doesn't show up everytime I run it. the last two times that I ran it, the first one went all the way through the 100 loops and the second one it crashed after few cycles giving me the text below

I should mention also that I get the same error (and same inconsistency) from the fingerprint calculator if I use the MACCS fingerprints.

has anyone seen something like this before?

thanks a lot in advance

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f0b918a7f34, pid=41147, tid=139686072264448
#
# JRE version: 7.0_07-b10
# Java VM: Java HotSpot(TM) 64-Bit Server VM (23.3-b01 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libstdc++.so.6+0x69f34]  std::_Rb_tree_rotate_left(std::_Rb_tree_node_base*, std::_Rb_tree_node_base*&)+0x4
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/giovanni.cianchetta/hs_err_pid41147.log
#
# If you would like to submit a bug report, please visit:
#   http://bugreport.sun.com/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

 

Dear Giovanni,

thanks for reporting this issue. Would it be possible to make some additional information available? The file /home/giovanni.cianchetta/hs_err_pid41147.log that is mentioned above might be useful. And maybe you could also enable KNIME to generate a core dump and attach it.

Kind regards,

Manuel

Any luck? On a new linux x86_64 install with linuxmint mate 16 and a couple of others too, it crashes with the same error. Oracle java, or openjava 1.6/1.7 do not make ny difference.

 

Linux U5-DT-Linux-13 3.11-2-amd64 #1 SMP Debian 3.11.10-1 (2013-12-04) x86_64 GNU/Linux

 

Please make the *pid*.log file available that is mentioned in the crash message. This could help to identify the cause.

Is KNIME running with LOCALE set to C? It is known that the RDKit nodes cannot handle LOCALE DE or other local settings for instance. There has been a change in Java 1.7 that handles the LOCALE setting now different when working with native libraries that it was before. Not sure though if your issue is related to this at all.  

-Manuel

Hi Folks,

I just updated RDKit and the problem seems to be gone!

I will test the issue more thoroughly but, so far, it looks good

 

Giovanni