ERROR Google Address Geocoder


i´ve got this error message from the Google Address Geocoder after 4% reading the data.

ERROR Google Address Geocoder 4:737 Execute failed: ws.palladian.extraction.location.geocoder.GeocoderException: Received status code OVER_QUERY_LIMIT

This is the data file with about 12000 lines:

Is the data table too big or how should I understand the error message?

Thx in advance

Google claims they allow (for the free plan) 15,000 requests/month and I was usually able to use the node within these dimensions, but probably they introduced some more restrictive rate limiting recently (afair there was a similar post recently). You might want to try running this in chunks and introduce a Wait in between or give the other Geocoder node a try:

For your data, also the Palladian Location Extractor might be well suited, as you’re obviously only interested in City-level accuracy (and not full street address geocoding):

If you want to give this a try, I would simply concatenate all place names per row into one line, such as ort landkreis bundesland and the extractor should be able to disambiguate to the appropriate location automatically. It uses the Geonames API and provides an optional integration with locally running Gazetteers for higher request volumes and/or privacy.



Hi @qqilihq ,

thx for your fast reply and your good information.

I`ll try it asap-


Ok first Step " Reducing the data" down to 317 lines didn´t change anything. :neutral_face:


Location Extractor

Execute failed: No LocationSources are enabled, thus no locations can be extracted. Please check the settings and activate at least one LocationSource.

Settings of KNIME / Palladin or Setting of ?

For the Location Extractor it’s this one:

For the MapQuest Geocoder it’s this:


hi @qqilihq ,

i set this :neutral_face:
2022-03-10 15_51_05-Preferences
2022-03-10 15_51_55-Preferences
I guess i have confirm my Emailadress first for this node!


MapQuest Geocoder works now!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.