Error in KNIME 3.4 with reporting


Using Knime 3.4.0 on MAC OS v10.12.5

When I read in a small 4 X 3 CSV file and attach it to a reporter node I see the correct file at the reporter node. (see screen copy attached)

When I then call the reporter using the Icone or menu I get the message (screen copy attached):

The file has been deleted from the fiel system. Do you want to save your changes or close the editor without saving?

I press save and get the "save as" message (screen copy attached):

When I choose cancel as only possibility I get the following exception error (also attached)

Really gutted I can not get this to work.
Hope one or another KNIME wizard can help me
Kind regards


Hi Kristof,

Is this maybe related to this issue:



Hello, dear KNIMErs,

opening the Reporting Tool I get the same error messages as Kristof (see screen_shot_2017-07-12_at_13.05.07.png and screen_shot_2017-07-12_at_12.59.33.png), but with a little variation in the final error message:

"An error has occurred. See error log for more details. java.lang.RuntimeException: No "workflow.knime" file in directory [Workflow Folder]".

The console just states "ERROR KnimeReportHandle               Error while handling editor switch!"

Having created a workflow with report, I get this error when I use the "Save as" option. Deleting the two default report files (see… ) does not help. I also get the error when I export a workflow with report and import it in another workspace folder.

I use KNIME 3.4.1 on Windows 7 64bit



Hey Kristof, hey Alex,

What information does your logfile contain regarding this problem? Can you upload it?

Sometimes the reporting is a little picky regarding file locations. Can you try a fresh workspace and import the workflow, or even better, recreate the workflow and test whether that solves it?


Since i’ve the same problem of Kristof, i don’t open a new topic.

My Config:
MacOs BigSur 11.3
Knime 4.3.1
Birt Framework 4.9.0

(jut for info…I had the same problem with previous version of MacOs and Knime…)

When I click on the report icon the page of BIRT opens and I get the same error message:
“The file has been deleted from the fiel system. Do you want to save your changes or close the editor without saving?”
Then everything is blocked and i’ve to kill Knime process e restart the program again.

Anyone can help?

i solved this problem (now i’ve a new one, but i’ll post it in a different thread).
The solution was to create a new workflow on the pc, to copy e to paste all nodes in the new wflw.
Doing this actions i didn’t get any error message when i click in the report icon.
Thanks anyway.

1 Like

I have this same problem with a workflow in KNIME 4.6.2 downloaded from our KNIME server instance. I have tried creating a new workflow, copying all the nodes across, and then copying the default_report.rptconfig and default_report.rptdesign files across into the new workflow, and the same problem persists. Another version of this same workflow has identical contents in both of those files and the report editor opens without any problem at all.

Furthermore, whichever option I choose in the dialog, the workflow editor pane disappears and as far as I can find, the only way to get it back is to restart KNIME. I’ve scoured the log files, but can see nothing untoward in there (no exception stack traces, no errors logged etc)


Looking back over the answers above andin the linked topic here (updated link for ‘new’ forum!):

The workaround in my case is to delete those 2 report files completely (save a copy somewhere if you want the report back!) - restart KNIME, open the report again - which will now ask you to save the files somewhere else - just click on the folder corresponding to the workflow and allow overwrite (overwrite what is a mystery, as the files are deleted above!) - the report editor will now open with a blank report. Save and close the workflow, and copy your original 2 .rptconfig / .rptdesign files back into the workflow directory, and reopen the workflow…

What’s going on here, or why this somewhat concoluted workaround is required is something of a mystery!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.