Error in testing BIRT report

I’m trying to create a BIRT report and in the phase of prelimiary testing of Master Page. I tried to pre-view the master page in web Viewer but it returned this error message:

image

I tried with some exsercise available on the Hub and it doesn’t happen but I don’t understand where are the difference in the configurations.

Below a screenshot of BIRT editor (Sorry but I cancelled some information from the picture for the obvious reasons!!).

Thanks

Regards

In the past I’ve seen this happen when the report contains some “unusual” ASCII characters, for example those with diacritical marks like ñ.

If you have any characters like that in your report, does removing them solve the problem?

Actually there was some “à” in the workflow file name and in some columns names, I cleaned these characters but there are still some problems that I’m not able to fix.
Now when I try to test the BIRT report in the web wiewer the page is open but report an error, see below:

Is it possible that some diacritical character (like à, è etc.) inside the original data-set can create this problem?
Thanks

It might be there is a hidden special character hiding out some place in your data, but sometimes that particular error occurs when changing the underlying structure of a table after the report has already been constructed.

Do you have an example workflow and small dataset that you can upload that demonstrates the problem?

Hi Scott,

No, I have nothing ready to upload that demonstrates the problem.
The original workflow is a bit complex and put together several data set.
I’ll see if I can simulate the error with the final data, post-transformation, cleaning and "camouflage of sensitive information. If I can reproduce the error I’ll share with you an example of workflow.
I’ll get back to you as soon as I can!
Kind Regards.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.