Error: KnimePandasExtensionArray cannot be created from factorized yet.

Hello to Knime community,

I am newbie and I would like to ask your help and advise about an issue running my Python script. My script that filter some data working perfectly in Pycharm using Conda environment. I use the same environment in Knime but I get an error:

ā€œpython Script 8:459:460: Execute failed: NotImplementedError: KnimePandasExtensionArray cannot be created from factorized yet.ā€

I have a filter that might cause the problem but I am not sure if that cause the problem:
for (x, y), k in groupDATA:
len(k) == 2

Please, what steps you suggest to follow to find what cause the problem. Could be the data? or the python code? or something else?

Any help or advise it would be more than welcome

Some info might help:
in Knime:
sys version
3.9.18 (main, Sep 11 2023, 14:09:26) [MSC v.1916 64 bit (AMD64)]
pandas version
2.0.3
in Conda:
Python 3.9.18

Hi @freebluek,

maybe the knime log or the log console within the Script editor shows in which line exactly that error occurs?

It is most likely due to some missing conversion functionality in KNIME.
We are aware of it, but cannot say when we get to it. I added this thread in the corresponding ticket.

As mentioned in the above link, you might need to do a explicit conversion to ā€¦ pandas? I have no idea what you are doing :wink:
See here for an example.

Can you tweak your code like the example and tell me whether it helps? If not, please have a close look at the aforementioned knime log and the console within the script editor and provide them as well as a minimal example to reproduce the issue :slight_smile:

Thanks and best regards
Steffen

4 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.