"Error Mounting KNIME Example Server"

On a brand-new Mac running OS 10.10, I'm getting the following message when starting KNIME 2.10.3. As I don't have this issue on my other machines running an older OS, I suspect the issue is OS-related.

Already known? If further details are required, let me know.

I have seen this before as well and we are investigating it.  I believe it only happens if you have your wireless adapter on, and are not connected to the internet just fyi. 

Thanks for the report.

Aaron, thank you for the feedback.

I also have to clarify the issue: It's nothing OS 10.10-specific, but also happened on my old machine. From my standpoint, I can confirm your statement, that it only seems to happen on WiFi connections, as I'm having no issues at the office via Ethernet cable.


FYI: Explicitely setting the machine's hostname solved my issue (and explains, why it's working in some network environments, as opposed to others):

sudo scutil --set HostName computername.local


The steps bellow worked for me:

  1. Open Terminal
  2. Type the code bellow, it will show what is your current computer hostname.
  3. Type the code bellow but replace the "computername" part with the name you want, just make sure it ends with ".local", it will ask for the password, don't forget to type it. 
    sudo scutil --set HostName computername.local

Done, just close and open Knime again, it will not show the error.

Many thanks guys - it worked for me too!