Error: object ‘’ not found

Hello - I am getting a ‘’ not found error when I try to test R. I have R 3.4.0 and latest KNIME versions. I get the same error with R v3.6.x.

knime.out ← is all I am testing.

Does anyone know how to fix this?


Could you make sure your version and setup of KNIME and R is up and running?

The new KNIME 4.4 offers an environment propagation for R via conda, although I have not yet found an example I could offer:

And frankly I would have to do more experimentation with the

In oder to realise the full potential.


Hello @sw1336
Did you manage to fix the error?
Some common missing when trying to run R from KNIME, besides fixing the path to R home, that I am assuming it is done to get the error…

Then other common misses are to install a couple of packages that are required in your R CRAN console or RStudio:

> install.packages("Rserve") 
> install.packages("rJava")

NOTE.- ‘Rserve’ is referred in the the ‘official KNIME and R guide’ linked by @mlauber71, however i didn’t see ‘rJava’ in the document

I hope this can help to fix the error

1 Like

Hi @gonhaddock - thank you for following up. Yes, managed to get it to work. I was trying to read a location and Path columns. Once I changed Path to string (I needed the path of the files), then it worked.



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.