Error on Impala Query

Dear Knime Forum

I create a simple workflow using the Impala Connector as described in the documentation.
I continue to obtain the subsequent error

ERROR Database Reader 0:11 Execute failed: [Cloudera]ImpalaJDBCDriver ERROR processing query/statement. Error Code: 0, SQL state: TStatus(statusCode:ERROR_STATUS, sqlState:HY000, errorMessage:AuthorizationException: User ‘’ does not have privileges to execute ‘SELECT’ on: xxx.yyy
), Query: select tndg from xxx.yyy limit 100.

the user seems to be empty even if it is correctly configured in the Impala connector. All connections are correctly configured so I don’t know how to solve the error

Thanks
Best Regards

Davide

Hey @DavidSeas
Could you try to add
AuthMech=2;UID= userName
or
AuthMech=3;UID= userName;PWD=*** (if you are using a password)
to the JBDC paramters in the Connector Settings?

I tried with these parameters but it doesn’t work

Are you using the current driver? You can download it here: https://www.cloudera.com/downloads/connectors/impala/jdbc/2-5-5.html

Yes I’m using the official cloudera driver

@DavidSeas

Did you get the same Error with the AuthMech setting?