Error opening workflow editor in Knime 2.8.1

Dear Knime users,

I am using 64 bit CentOS 6.4 . I updated my Knime 2.7.1 to 2.8.1 recently and I get the following error in the workflow editor:


Could not open the editor: An exception was thrown during initialization

    at org.knime.workbench.editor2.WorkflowEditor.setInput(
    at org.knime.workbench.editor2.WorkflowEditor.init(
    at org.eclipse.ui.internal.EditorManager.createSite(
    at org.eclipse.ui.internal.EditorReference.createPartHelper(
    at org.eclipse.ui.internal.EditorReference.createPart(
    at org.eclipse.ui.internal.WorkbenchPartReference.getPart(
    at org.eclipse.ui.internal.PartPane.setVisible(
    at org.eclipse.ui.internal.presentations.PresentablePart.setVisible(
    at org.eclipse.ui.internal.presentations.util.TabbedStackPresentation.selectPart(
    at org.eclipse.ui.internal.PartStack.refreshPresentationSelection(
    at org.eclipse.ui.internal.PartStack.setSelection(
    at org.eclipse.ui.internal.PartStack.showPart(
    at org.eclipse.ui.internal.PartStack.add(
    at org.eclipse.ui.internal.EditorStack.add(
    at org.eclipse.ui.internal.PartStack.add(
    at org.eclipse.ui.internal.EditorStack.add(
    at org.eclipse.ui.internal.EditorSashContainer.addEditor(
    at org.eclipse.ui.internal.EditorAreaHelper.addToLayout(
    at org.eclipse.ui.internal.EditorAreaHelper.addEditor(
    at org.eclipse.ui.internal.EditorManager.createEditorTab(
    at org.eclipse.ui.internal.EditorManager.openEditorFromDescriptor(
    at org.eclipse.ui.internal.EditorManager.openEditor(
    at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched(
    at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(
    at org.eclipse.ui.internal.WorkbenchPage.access$11(
    at org.eclipse.ui.internal.WorkbenchPage$
    at org.eclipse.swt.custom.BusyIndicator.showWhile(
    at org.eclipse.ui.internal.WorkbenchPage.openEditor(
    at org.eclipse.ui.internal.WorkbenchPage.openEditor(
    at org.eclipse.ui.internal.WorkbenchPage.openEditor(
    at org.eclipse.ui.ide.IDE.openEditorOnFileStore(
    at org.knime.workbench.ui.navigator.KnimeResourceNavigator.handleOpen(
    at org.knime.workbench.ui.navigator.KnimeResourceNavigator$3$
    at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(
    at org.eclipse.swt.widgets.Display.runAsyncMessages(
    at org.eclipse.swt.widgets.Display.readAndDispatch(
    at org.eclipse.ui.internal.Workbench.runEventLoop(
    at org.eclipse.ui.internal.Workbench.runUI(
    at org.eclipse.ui.internal.Workbench.access$4(
    at org.eclipse.ui.internal.Workbench$
    at org.eclipse.core.databinding.observable.Realm.runWithDefault(
    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(
    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(
    at org.knime.product.rcp.KNIMEApplication.start(
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(
    at java.lang.reflect.Method.invoke(
    at org.eclipse.equinox.launcher.Main.invokeFramework(
    at org.eclipse.equinox.launcher.Main.basicRun(
    at org.eclipse.equinox.launcher.Main.main(


This error is not only for the new workflow editors but also the existing ones. So, I tried to install Knime 2.8.0 and 2.8.1, but it again gave me the same error. I could work with 2.7.x versions again, but I am having a hard time re-installing nodes because of conflicting dependancies or the 2.8 nodes are not compatible (any solution for this, btw?).

Anyone else came across this problem? If yes, any clue how to solve it?

Best regards




Hi Rohit,

We do use some linux here in house, and I just tried to reproduce this problem on a CentOS system but to no avail.  Can you provide some more details, perhaps regarding how you installed KNIME and then also how you updated it? 


Hello Aaron,

I install knime usually by the normal method - downloading the compressed file, uncompress it and run the executable.

For the update from 2.7.1 to 2.8.1, I simply clicked on Help>Check for updates. I am having this problem only with 2.8.x.

Maybe for now I could work with 2.7.x because that version seems to be working fine. Is their any way that when I install new nodes, I can somehow ignore the nodes compatible with 2.8.x version? Because it always gives me conflicting dependencies error.



Best regards


Are the workflows you are trying to open also visible in the KNIME Explorer under the Local Workspace? It may be an issue with linked workflows that are outside the local workspace.

Hello thor,

Yes, all the workflows are clearly visible. Things have changed a bit since my last post:

1) Upon restarting (accidental I may add!) of my system, the 2.7.1 -> 2.8.1 works, but as for installing new nodes (for example Marvin Chemistry nodes), I do not see them in my node repository but when I want to install the nodes from any update site, it tells me that all the nodes are already installed.

2) When I installed a fresh version of 2.8.1, I tried to open a new workflow (nothing was open before) and I am unable to do that. No matter how many times I click 'next', it doesn't go any further.

Appreciate all the help you guys can provide.




As for point #2 from my last post, the workflow opens now, but with the same error as mentioned in my initial post.

Are you using the old "Workflow projects" view or the new "KNIME Explorer"?

I have tried both, they end up with the same error. (In the new Knime 2.8.1 install)

In the Knime 2.7.1 -> 2.8.1 version, where I lost some nodes , the workflow projects are opening but corresponding nodes are not there and when I try to install those nodes it tells me they are already installed. Is there a reason why Knime is telling me the nodes are already installed, when they are not?

Also, is there a way to avoid 'conflicting dependencies' if I install 2.7.1 (as 2.7 version seems to be working fine for me) because all the sources point to 2.8 version nodes? Is there a way to install nodes corresponding only to the 2.7 version?



If an extension is installed and the nodes are not showing up, then something is really wrong with your installation. Can you send me (per mail to if you like) the following log files: <workspace>/.metadata/.log and <workspace>/.metadata/knime/knime.log.

Usually it is not possible to install new nodes into an older KNIME version because they use functionality that is not available in the previous version. If you want to install nodes into you 2.7 and it grabs the 2.8 versions then use the following update site URL: