Error Python Script Lab

Hey colleages,
currently, I have this issue with Python Script Lab.
It gives me a error “not initialize lz4” but I have this in extension folder.

Thanks in advance!!!
Have a good code weekennd

@MoLa_Data you might want to take a look at this example and see if the Conda Environment propagation could help:

Could you make sure you have your anaconda or better miniconda Python setup running and maybe provide us with further informations about your environment and operating system.

Sorry to omit this, but I was already using Conda.
I have read all documentation but it don’t says nothing about that.

@MoLa_Data the point would be to use the environment propagation from the example. If you just use the node it would just reproduce your current environment.

To be honest I found the concept somewhat confusing myself in the beginning.

Well, It’s continue without run :weary:
It’s possible that If I change the lz4 folder, It’s work good?

@MoLa_Data not really much information to go with. You could just check if your idea would make any difference I have outlined a few things you could do and informations you could provide us with. Maybe you could start elaborating how your system is set up and how your Python environment is doing and what your experiences are with the Conda Environment examples.

I’ll try removing and installing a new environment.


Hi @MoLa_Data,

could it be that you upgraded your KNIME version from 4.4 to 4.5 and then installed the Python Scripting (Labs) extension?
In that case, could you check whether the “KNIME Columnar Table Backend” is installed by opening up KNIME and go to File → Install KNIME Extensions and search for “Columnar”. If you tick/untick the “hide items that are already installed” checkbox on the lower right you should find the Columnar Table Backend feature. This is the one containing the LZ4 libraries. We are investigating why the Columnar Table Backend feature is not always installed with the Python Script (Labs) extension.

Please let us know whether that helps.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.