ERROR SDF reader

The SDF reader no longer reads the structure portion of the file (all meta data in the sdf is read) and gives the error:
ERROR SDF Reader 5:1513 Configure failed (UnsatisfiedLinkError): no silib in java.library.path: /Users/mattperry/Library/Java/Extensions:/Library/Java/Extensions:/Network/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java:.

I am currently running Knime 4.7.7 and everything is up to date. I have tried to delete and add the sdf reader, uninstalled knime and reinstalled, but nothing has worked so far.

Any help would be appreciated.

Hi @MP_88707913 and welcome to the forum.

I tried reproducing the issue just now with a sample SDF and was not successful - but then again, I am not a chemist so I am probably using something too simple.

Can you upload a sample SDF and/or workflow that reliably reproduces the problem?

Can you post the complete stack trace from the log file? The SDF Reader doesn’t use any native libraries therefore I’m wondering where this error comes from.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.