ERROR SparkProviderRegistry

Hi there, after updating to KNIME Analytics Platform 4.2 and installing all the extensions (I had before) I got some issues with my spark enviroment:

ERROR SparkProviderRegistry Problems during initialization of Spark provider with id ‘org.knime.bigdata.spark.core.databricks.DatabricksNodeFactoryProvider’. Exception: Plug-in org.knime.bigdata.databricks was unable to load class org.knime.bigdata.spark.core.databricks.DatabricksNodeFactoryProvider.

Did I miss any extension oder setting?

I installed

  1. KNIME Lab Extensions
  2. KNIME Big Data Extensions
  3. KNIME Server Connector → KNIME ServerSpace
  4. KNIME Server Connector → KNIME Remote Workflow Editor
  5. KNIME Amazon Redshift Connector and Tools
  6. KNIME Amazon Redshift Driver
  7. KNIME Optimization Extension

Cheers Tom

Hi @Tom-Kuehner,
can you please set your KNIME log to debug:


restart the analytics platform and then post your KNIME log here?

Also, you can try re-installing the databricks extension.

best,
Gabriel

Hi Log Level is already set to DEBUG.
If you look at the latest entries you will see the issue …
I will try reinstall the databricks extension
knime.log (3.1 MB)

Reinstallation didn’t worked:

WARN DBTypeRegistry Uninstantiable default attribute definition supplier for the database type of ID databricks in extension:org.knime.bigdata.databricks
ERROR SparkProviderRegistry Problems during initialization of Spark provider with id ‘org.knime.bigdata.spark.core.databricks.DatabricksNodeFactoryProvider’. Exception: Plug-in org.knime.bigdata.databricks was unable to load class org.knime.bigdata.spark.core.databricks.DatabricksNodeFactoryProvider.
ERROR SparkProviderRegistry Extension org.knime.bigdata.databricks ignored.
ERROR RepositoryManager Node ‘org.knime.bigdata.dbfs.node.connector.DBFSConnectionInformationNodeFactory’ from plugin ‘org.knime.bigdata.databricks’ could not be created. The corresponding plugin bundle could not be activated!

I deinstalled all Big Data Extensions and reinstalled them, now it works again.

1 Like

Hi @Tom-Kuehner,

I am happy reinstalling worked for you.

best,
Gabriel

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.