Error uploading python nodes

knimelogs.txt (85.3 KB)
I’m trying to upload a workflow consisting of two nodes that run python scripts. This workflow works if I run it in the Analytic Platform, but when I upload it to the server and try to run it from the webportal, I get the following errors:

Errors loading workflow ‘read&write_elastic’: Status: DataLoadError: read&write_elastic 0 loaded with error during data load
Status: DataLoadError: read&write_elastic 0
Status: DataLoadError: Python Source 0:1
Status: DataLoadError: Unable to load port content for node “Python Source”: Unknown table identifier: container_table_compressed
Status: DataLoadError: State has changed from EXECUTED to CONFIGURED
Status: Error: Python Script (1⇒1) 0:3
Status: Error: Loading model settings failed: Coding issue: No enum constant org.knime.python2.kernel.PythonKernelOptions.PythonVersionOption.python3
Status: DataLoadError: State has changed from CONFIGURED to IDLE

I’m sending the logs as well for the last couple hours.

I checked to see if the executor from the server had the python nodes extensions installed, which it has and the path to a python executable is also set, for the same version as the one I am using in my personal computer. I tried to download the workflow from the server onto my executor and got these same errors and when I looked into the nodes they were empty.

Something maybe worth noting, my executor and Analytics Platform versions are different. My Analytics Platform is 4.0.0 and my server executor is 3.7.2. Not sure if that affects anything.

Any help will be appreciated.

Yes, that’s the cause. Python nodes are not forward compatible to KNIME Analytics Platform 4.0. That is, you can’t run workflows containing Python nodes that were created using KNIME AP 4.0 in any older KNIME AP installation.

Note that all Python nodes are still backward compatible, that is, workflows created by older KNIME AP versions still work in KNIME AP 4.0.

4 Likes

Oh thank you for the help. Can the information on whether a given node is/isn’t forward compatible be found anywhere?

Hi @TomasCardoso,

there is no general rule and this can differ between releases X and Y and X and Z. So in general, if you use release A and you have to open a workflow that was saved in release B, then if A is older than B you should not expect that it will work. The opposite, i.e. opening a workflow that was saved with an older release is expected to work.

Cheers,
Mischa

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.