Error when trying to delete a user group

#1

Hello,

I recently installed KNIME server 4.9.2 on a Windows machine. In the process of configuring users I successfully created a group, but I realized a short while later that I misspelled it. When I try to delete said group, I get the error message:

Error: You do not have the necessary permissions. (status: 403, status text: error).

Does anyone know what might be going on?
Thanks!

0 Likes

#2

Hi @elsamuel,

Where exactly do you try to delete the group? Is this on the WebPortal?

Cheers,
Roland

0 Likes

#3

Hi @RolandBurger

Thanks for your reply. I’m working in the administration section of the webportal. After some troubleshooting it looks like the problem is the presence of a space in the group name. I still haven’t figured out a way to delete the offending groups though.

0 Likes

#4

Hi @elsamuel,

I just tried this on our end, and couldn’t reproduce it. Just to confirm, I created a new group whose name contains a space “test group”, and deleted it afterwards. There were no issues.

Can you delete groups whose name doesn’t have a space? I.e., does the problem only affect one particular group, or is this a general thing?

Cheers,
Roland

0 Likes

#5

@RolandBurger that is quite odd. Just now I created two groups, one called “test group” and the other “testgroup”, I successfully deleted “testgroup” but “test group” gave the same error that I got previously. This behavior has been consistent, so it does seem like a general issue on my end.

0 Likes

#6

Weird… :frowning: Can you please give it another try, then download the log files and send them to me? (Via private message). It’ll be enough if you just send today’s logs.

Plus, on the off chance that this is relevant, which OS and browser are you using for the WebPortal?

Cheers,
Roland

0 Likes

#8

Sorry for the delayed reply. Last week was a slow week here in the US.

I tried again this morning and got the same results:

  • I successfully created and deleted a group with no spaces in the name
  • I created a group with a space in the name and couldn’t deleted it
  • I still can’t delete any of the previous groups whose names contain spaces

The server is running on a Windows 10 Enterprise machine, and I’m using Firefox on a Windows 10 Pro machine to access the Webportal, logged in as knimeadmin. Switching to Chrome on my machine made no difference. Neither did working directly on the server in either Firefox or Chrome. There’s also no difference if I log in as an admin that I created previously.

I haven’t quite figured how to send a private message, so here are the log files:
catalina.2019-12-02.log (1.2 KB)
localhost.2019-12-02.log (10.7 KB)
localhost_access_log.2019-12-02.txt (53.6 KB)
knime.log (4.7 KB)
knime.log (112.9 KB)

0 Likes

#9

Hi @elsamuel,

I was just able to reproduce this; it happens since you’re on a Server Small, which doesn’t have consumers added to the license. We’re not sure why it only happens if there is a space in the group name, but it’s certainly something we need to fix.

In the meantime, easiest workaround is if we just send you a new license file. Can you please send an email to support@knime.com, linking to this thread?

Cheers,
Roland

1 Like

#10

@RolandBurger will do, thanks!

1 Like