Error while connecting Knime with S3 bucket

Hi All,

I am facing issue while connecting Knime with S3 bucket.

I am getting error “Unable to access the file”, I have checked all my login and everything is fine.

It will be very helpful if someone can help me with this issue.

Udit Ramani

Hi @uditramani and welcome to the forum. I moved your post to the main Analytics Platform category since it gets the most traffic :slight_smile:

As to your question: have you checked our documentation? There is a specific section for connecting to S3: KNIME File Handling Guide. We also have a specific example on the KNIME Hub:

If you’re still having trouble, please upload an example workflow showing what you’ve tried.

I would check access rights first. That is very often the issue for me with aws services.

1 Like

Hi Scott,

Thank you for your response.

I have tried using same way but it is giving me an error.

Also please find the below flow which I am following:

Amazon Authentication Node:

I tried test connection and it is connecting correctly to my S3 bucket.

Amazon S3 connector Node:

Please do let me know if this is correct or I need to change anything.

Udit Ramani

Hi Daniel,

Thank you for your response.

I have checked my access rights and they are correct.

Udit Ramani

If possible always post the complete error message

Hi @uditramani

  1. Permission to this bucket does not mean, that you have automatically the rights to do different things to the content in the bucket, e.g. read, write, delete object or create folders.
  2. try one “/” instead of two “//” for your filepath-name

gr. Hans


Hi Hans,

I have checked my access rights and it is similar with my other colleague who can run this Knime flow on his laptop.

Also I have tried using one “/” as well but still getting same error message.

He can run the same workflow you shared with him with his credentials (inside the same company network, firewall, proxy,…,ports…) and he is no admin on his machine?
If so different access rights to aws is the only issue I can think of

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.