error while executing python node in server

Hi I am new to Knime,I tried to run a python script node in workflow, since the file is big(>1GB) it is showing memory problem.So I tried to ran it on web portal and it is showing the following.Can anyone please help me out.
i am python 2.7 and also how can I solve memory issue.


Please see here for how to increase the amount of memory allocated to KNIME:

To use Python on the server, you have to add the path to your Python installation to a preference file. You find this in <server_dir>/workflow_repository/config. There is a file named “preferences.epf.template”. You need to edit this file to include the paths to your Python installation and then save it as “preferences.epf” in the same location. You’ll have to restart the server process to apply the changes.

In addition to this, from your screenshot, it looks like the Python nodes are not installed in your server executor. The easiest way to do this is to start up the server executor and install the extensions the same way you would install them in your local KNIME client.


How would I go about adding the path to the python installation on an AWS Ubuntu server with no GUI? Or is this a change I can do in the webportal?