Error while writing to an excel in sharepoint


I am writing an excel file into my sharepoint folder. However it throws an error
Execute failed: Invalid request

I am connecting the same sharepoint online connector which i used for reading my files. The read works but the write doesn’t. The error is similar when tried with table writer.
Any help?

Hey r_jain,

Would you mind to provide additional information regarding the issue?

What is the version of your KNIME Analytic Platform?
If possible, can you show the failed workflow?

I am on 4.7 version.

This might be the issue of my organization which may not allow write privileges through KNIME, something related to whitelisting perhaps?
The workflow is really simple, just a microsoft authentication which is connected to sharepoint connector and then reads file through excel reader and finally writes to the excel writer.
Nothing related to the settings i believe!

Hey r_jain,

Permission to write is definitely required. Would you mind to try request permission and see if that fix the problem?

You can view KNIME log file and it provides more details on the error messages. Feel free to paste it here if your problem can’t be solved.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.