Error Whilst Running Workflow - setPermissionsToOwnerOnly

I’ve been running a workflow via a batch file, recently the same workflow has been failing consistently with the following error: setPermissionsTOOwnerOnly
Warning: unable to change permission for owner:

Oddly, when I manually run the workflow all is well and the workflow completes. When running the workflow using the batch file and scheduler it fails.

Iv’e exported the preferences file again to ensure the settings used are the latest.

I assume the workflow is failing on a module that communicates with google-api to retrieve data from a google-sheet but I am not certain about that.
What I fail to understand is the error which suggests their is a permissions issue on a temporary file, is the workflow temporary storing a file retrieved from google-api but the workflow doesn’t have permission to access it?

Do you have any suggestions?

What I’ve tried since.
Running Windows 10.

  • Upgrade to the latest KNIME version.
  • Run the batch file as Admin.
  • Run the batch file both via CMD and via Windows scheduler.
  • Config KNIME to run as Administrator only and then re-execute the batch-file.

None of the above work, I am getting the same error each time.

I’ve looked all over the community forum and searched the web, the suggestions above came from the web and there was also a suggestion the cause it related to Java and the Google API - where individuals solved the issue for their own application not KNIME directly.

Has anyone experienced this similar error ?
Does anyone have ideas what else I could try?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.