Error with Node "Open in Matlab" or "Plot in Matlab"

Hey, i´ve got the problem, that i cant connect Knime with Matlab. The Knime Version is XXXX. Matlab is installed in Version "R2015b" and "R2016b". But when i try to start the "Open in Matlab" Node there is an Error:

 

slides

In Matlab is the "Statistics and Machine Learning Toolbox" installed (Version 11) and the path of Matlab installation is without spaces.

I dont know what to do or test for getting this problem solved. Maybe you have any suggestions to solve it.

 

Is there any chance to tell KNIME where my matlab installation is or can it be a problem, that i´ve got two versions installed?

Is there any chance to tell KNIME where my matlab installation is or can it be a problem, that i´ve got two versions installed?

I believe it's the KNIME installation that should be on a path without spaces in order to use MATLAB scripting. The MATLAB installation should probably be in its default location. Note that although the help for the MATLAB scripting nodes tells you to "make sure that the Matlab server is running somewhere", the documentation at https://github.com/knime-mpicbg/knime-scripting/wiki/Matlab-server-for-knime and the discussion at https://tech.knime.org/forum/scripting-integrations/matlab-snippet-doesnt-work-anymore confirm that this hasn't been the case since KNIME 2.10 - perhaps someone should update this?

 

Having said all that, while I have successfully tested MATLAB scripting in the past, it doesn't seem to be working for me right now (KNIME 3.3.1, MATLAB R2016b) - trying to run a simple snippet is giving me a range of errors such as Execute failed: Method did not return properly because of an internal MATLAB exception (in the KNIME tooltip) and Output argument "mOut" (and maybe others) not assigned during call to "snipped_8011860580379423744". (in the MATLAB console).

 

Is anyone else having trouble with the MATLAB scripting?

Thanks for your help. I thought Knime was installed without spaces, but although in German its called "C/Programme" Windows is working with "C/Program Files"... Now Matlab is starting out of Knime, but producing a lot of Errors:

DB Table Selector node

Someone an idea what the problem is?