Excel Reader and formated cells

Hi All,

Maybe some of you have faced with this.
When reading a Excel sheet, the “Excel Reader (XLS)” node is taking in to account the format of the cell.
I.e.: number cells with 10+ decimal places but set to show only 2.
I would like to read them with all decimal places, without having to open excel and chage the format.
image
Note: We use comas as decimal separator.

With a python script the data comes without formatting, but I would like to use the Excel reading node to simplify the flow.
Is there a way to overcome this?

Hi,
i’ve tried to replicate your problem.
Here u can see the example excel file, with number with 6 decimal places, but formatted to see only the first 2.
image

and here we have the output by excel reader node, in the standard configuration.
image

but if you right click on the header of a column you can change the render, so u can choose full precision. now u’ll be able to see full decimal places.

image

Luca

2 Likes

Luca,

Is there a way to set this at the KNIME preferences or any other place?
The spreadsheets have a variable number of columns.

Thank you.

I’ve found!

Thank you!

4 Likes

Ok.

It´s only partially resolved. It does not workif the column has different types.

image

All numbers in this sheet are double precision with 10+ decimal places.
Part of the KNIME job is to replace these “NA”.

Hello @mpsz,

you are right. There is already a ticket to handle it and will add +1 to it.
(Internal reference: AP-14929)

Br,
Ivan

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.