Excel reader and writer

Hi :slight_smile:

I have a question about new Excel Reader and writer.

  1. Is there a way to force Excel Reader to read all columns as strings? I have tried unchecked the option in Advanced settings in Table specification “Limit data rows scanned” but that did not work.

Some of the columns are read as date or number. I can not changed types in Tranaformation neither.

  1. Why the option of including and Excluding writtten columns in Excel Writer is taken away?

Thanks for help.

@89trunks you actually have several additional options to import Excel files.

For example you can use R to either force to import all columns as strings or let KNIME/R decide how to handle the types (but the new Excel File Reader will also do that):


hi @89trunks,

1: We’re working on this option
2. It has been taken away, since the node now allows multiple table inputs which in turn requires a more flexible column filter dialog / UI that would allow you to select the tables individually etc. As for now you’d have to use an additional column filter node prior to the excel writer. How valuable did you find the option to select the columns in the writer node? Do you think this would also be a good feature for other writers?

Thank you for your feedback and please excuse that the excel writer (currently) lacks this funtionality


It will be useful to have column filter in Excel Writer for sure. The balance of KNIME being a
developer tool or end user analysts one was broken in number of cases. It would be nice to keep both lines. Some times it could be done by using components but not always. In case of radical changes the conversion tool will be appreciated even if replacement will be in the form of component.

  1. Good to know.
  2. It was very helpful since you didn’t have to use extra node and sometimes at the end of workflow (before writing it to some file) I had to filter some columns - it was faster for me.
1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.