Excel Reader in the server does not work evey time

Hi all,
I have a basic workflow where I: (1) upload a file in ther server, (2) move the file to a temporary created folder and (3) read the file with Excel Reader.

We are now testing the new Knime Version and I noticed that this logic works for some excel files, but for others don’t. I have no idea what is the criteria is for it to work.

When I open the job in the server, this is what I see (For when it cannot read):

Any idea on what might be happening?


Hi Matheus,

Please add this line to your executor.epf file located at /config/client-profiles/executor/


And then restart the executor service. This should allow local file store access on the server, which may help with this.

In addition to this, would you mind answering a few questions to help us better understand the issue?

  1. Please send a screen shot of the basic workflow you have set up.
  2. Can you also attempt to swap the Excel Reader out for the File Reader node and see if you get the same results?
  3. Can you let us know what the file name is that you are attempting to upload when you see that error?
  4. It appears you are using a variable for the URL of the file, is that correct?
  5. Can you see the file name in the /tmp/ directory after the job has run?



is the flow variable you’re passing

If the flow variable is not using the knime protocol please change the read from location to local file system. With the additional adjustments explained by @ztrubow everything should work as expected.


Thanks for the input here. Based on your questions and comments, I think I was able to find out what was going wrong. I will try to explain it here.

The problem has to do with the uploaded file name having spaces (and the fact that I copy to a temp folder later). I was not able to spot where it goes wrong exactly. My solution was to give it a different name (without spaces) when copying to a temp folder (as opposed to keeping the original one).

A few remarks that I think it is useful to mention:

  • The setting /allow_local_fs_access_on_server=true did not seem to have any cimpact. I tried to read the file refrence direct form the upload and, even with this setting activated, I could not have direct access (which resulted in not being able to read the file, but with a different error message). For that reason, my solution involves copyting the file to a different folder.

  • In my original workflow, when I uploaded and read a KNIME table file (.table), even if it contains spaces, no issues occured.

  • The original workflow worked without issues in the 4.10 version (with 4.1.1 client).

Thanks again for the comments and if you would like to dig further, please let me know.


Here are the screenshots, for reference.


Moving file to temp (inside workflow)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.