excel reader issue : invalid relationship part/id

Hi All,

I seem to have struck a bit of a strange issue with the excel reader

invalid relationship part/id

this comes in the preview window, and also halts the processing for that reason

a couple of characteristics

  • using Knime 4.5.2
  • downloaded a google spreadsheet via the python googleapiclient package
  • there is a series of similar workbooks that i created by having created a template spreadsheet and then cloning that to create the actual spreadsheets, so they are virtually the same. I can’t really see anything different from one workbook to another.

Has anyone come across the same issue ?



Does that Google sheet turned Excel file contain a pivot table?

1 Like

Probably unrelated but have you tried using the:

@elsamuel , indeed, it did contain a pivot on another sheet.

After removal, it worked like a charm!

Thank you soo much!

@mlauber71 ,

to be honest, I’d have to play around with it! I know of it, but haven’t used it specifically though.

I’m a bit reluctant to have the credentials / auth token sitting in the workflow though…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.