Excel reader node

I am having trouble loading huge excel files on the excel reader node. Can anyone explain and advise please?

Hi @Shani -

What error are you seeing when the node fails? How large are the files you’re trying to load?

Absent any additional information, the first thing I’d try is increasing the amount of memory available to KNIME via the knime.ini config file.

1 Like

Hi @ScottF
My excel files are 150 mb or above. Error: “could not read file”

150MB doesn’t seem unreasonably large. Could you try increasing the value of the -Xmx parameter in knime.ini and see if that helps?

Another option might be to try encapsulating the Excel Reader node into a wrapped metanode, and enabling streaming, as described in these links:



Scott, I tried to wrap CSV Reader connected to the Row Filter into wrapped node. But node does not have the connection arrow and inside wrapped node there is no way to connect gray input and output parts to the CSV Reader and Row Filter. What I’m doing wrong? KNIME 3.6. on WIn 7 Pro.

Hi @izaychik63 -

Are you configuring your metanode to have a data output port? See steps below.



Thank you, Scott. This is what I missed.

1 Like

Thanks @ScottF. I increased the value of the xmx and its working great.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.