Excel reader showing inaccurate results

Hello! I created a workflow that is being run several times using different excel sources. Each time we execute the workflow, we manually change the source tables used. The problem is that when I change the source, the Excel Reader node reflects the table dimensions of the source that was used before instead of the current one. This leads to the output of the Excel Reader either missing several columns (if the previous source contain less columns than the current) or including empty columns. Is this an issue with the cache? I’ve already tried changing the option to 'Write table on disc" but still encountering the same issue.

@paumanuela welcome to the KNIME forum. You will have to allow changing file schemas in the settings


Thank you so much! This totally fixed the issue I had.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.