Excel Reader: The "Relative to" option does not work as expected


I’m experiencing issues with relative paths (“Relative to” option) in the Excel Reader node. One can use custom URLs to enter relative paths and bypass these issues.

Relative to > Current mountpoint:
Cannot access files inside any workflow directories.

Relative to > Current workflow data area:
Cannot access files inside any directory except current workflow data directory.

Relative to > Current workflow:
Cannot access files inside current workflow directory/sub-directories or any other workflow directories.

Using KNIME 4.2.2 on Windows 10.


1 Like

Hi @armingrudd

I have to admit what you are describing is completely as designed.
With the option to have access inside the workflow you are able to destroy the workflow. So when talking to users all use cases were around being able to write into any folder inside the workflow. But there was no need for a specific folder. That is why now only the data folder can be accessed.

With the custom URL option we wanted to give the advanced and longterm users the full functionality.

Do you have any use case which is not working with this setup?


There is this from @Iris:

KNIME Labs CSV Reader expecting variable of type path

And then I found that if you want to sort of browse a relative local path you had to enter a dot “.” in the empty field. Will have to check this on my machine.

1 Like

Hi @Iris,

Hmm… that sounds weird and at the same time kind of fair to me!
So now you are adding different options for beginners and advanced users?!
How about adding a checkbox for this option (“Relative to”) which lets you choose between a protected access and open access?



current mountpoint and current workflow treat workflows as if they were files (which cannot be read / written to) and therefore you cannot access anything that resides within a workflow. However, you should be able to write to and read files from workflow groups.

Reason that we enforce this behavior is that this way we can ensure that you’re not able to destory your workflows and any workflow created locally works on the server. This behavior is not guaranteed using knime urls.

current workflow data area does not allow you to access its parent directory, i.e., …/…/ does not work. This option allows you to create self-contained workflows.


Hi @Mark_Ortmann,

Thank you and @Iris for explaining reasons why the node has this behavior. As I said, it sounds somehow fair to me but still I think users should have the option to control this behavior.

Just a suggestion, I would go with custom URLs anyway! :wink:


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.