Execute failed: Exception occured during R initialization

Dear community,

I'm write here to know if someone have had a similar problem and how I can resolve it. I'm using Knime 3.1.0  via Citrix (and the embeded R version).

I'm using R nodes. In paritcular I have "Table to R" node to import data and write R code, and a second node, "R to table", to use the output data of the R script in order to continue my workflow.

The problem is on "R to table" node. When I run it, the following messages appear on console:

ERROR R to Table 0:81:28 Execute failed: Exception occured during R initialization.

ERROR R to Table 0:81:28 Execute failed: Error in R code: "Error: object 'completo' not found"

I would like to specify that some hours ago, it was working properly I didn't modify anything.

 

I look forward to hearing from someone of you.

Thank you.

Claudia

 

 

 

 

I'm not understarding the reason but the only way to resolve the issue is create a second dataframe copying in it the first. After that the "R to table" node includes all the dataset available. Without doing it, "R to table" has no workspaces available.

Claudia

 

Hi Claudia,

Thanks for the follow-up. Hard to say what the problem is. Does the error message "object 'completo' not found" mean anything to you?

Are you up-to-date with the latest R extensions that we distribute? There was a recent fix on the update site, which isn't available yet in the latest KNIME Analytics Platform bundle (3.1.2).

Thanks,

  Bernd

same here with Knime 3.1.2 on redhat linux cluster.  R 3.3.0 launches from cmd line fine, all packages are installed and working, all paths are set in knime preferences.  same error message in the knime client from the R View (table) node - "Execute failed: Exception occured during R initialization."

 Is there any way to debug this?

update: runs in batch ok.

Weird. Can you find more information in the knime.log file? Locate the error message "Execute failed: Exception occured during R initialization" and copy the "stacktrace" that follows it. It's some indented block of text.

If it runs in batch, then we should also get it to run in the UI application.