Execute Failed: targetURI invalid (trying to run Excel Sheet Appender)

Hi all,

Having a lot of trouble with what seems to be a simple Excel Sheet Appender node. I get an updated Excel sheet with new data every week. I am using Excel Reader to simply read certain rows from a certain worksheet in this weekly file. I then convert a couple of columns from string to number and then I want to drop it into another workbook (and overwrite an existing sheet) using Excel Sheet Appender.

When I hit execute on the Excel Sheet Appender, I get the following error: Execute failed: targetUri invalid - http://invalid.uri

A few things I’ve tried with different results:

  1. changed the location of the files from Box to a local folder on my computer (didn’t work)
  2. changed the destination workbook from xlsx to xls --> this actually worked! but it isn’t a sustainable solution because of the row limit of 65k in xls format.
  3. created a dummy xlsx file with a few spoof tabs and selected this as my final destination --> this also works so I’m very confused as to why my existing xlsx file won’t work.

The final file I want to append has like 20 tabs and lots of data. It’s about 45mb in size. Not sure if there’s a size limit issue? What gives? Any help would be much appreciated!

Hi @dking8,
could you share your KNIME log file so we can investigate this problem? You find it under View -> Open KNIME log in the Analytics Platform. If possible, it would be even better if we had a workflow to reproduce the problem. I’d understand if that does not work for you, though.
Kind regards

Alexander - I really appreciate the reply and willingness to help. I was able to figure out a solution but not sure I understand the root cause of the original issue.

I read on another semi-related post that Knime could have issues reading to an xlsx file with images or buttons so I deleted all of my images in the xlsx file. (I had inserted a bunch of rectangle shapes and used them as buttons hyperlinked to different tabs in the workbook). After deleting all of these and re-running the Knime workflow I got a different error stating “Execute failed: Java heap space”.

I googled that error and found that it could be a lack of memory allocated to Knime. By updating a text file within the Knime application directory, I was able to allocate more memory to Knime and it successfully ran.

Again, thanks for the willingness to help. Hopefully this thread helps someone else with a similar issue.

1 Like

Glad it worked out for you and good to know for the future that images cause problems!

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.