Execute workflow without "reset"

#1

Hi,
New user here, a little confused:
What does it mean to “reset”(f8) and shouldn’t this happen automatically on exit or startup?

I want to run the workflow in batch command, and am only getting it to work if I first open up in the GUI, reset the workflow, close, then run my command…sorta defeats the purpose of batch.

When I open the workflow, I can’t execute any node until after doing “reset”…why?.

0 Likes

#2

… because you’re often interested in a workflow’s last execution results. Automatically resetting would kind of make this impossible. However, why don’t you just add the -reset parameter when running your batch?

– Philipp

2 Likes

#3

Excellent! This works, thanks

1 Like

#4

Hi there @mcrad,

Welcome to KNIME Community Forum!

In order for workflow to be run in batch mode it needs to be reset state (same as in GUI actually). Upon batch execution workflow is automatically saved. You can use -nosave parameter and then workflow will not be saved upon execution or you can use -reset parameter as @qqilihq suggested and workflow will be reset before execution.

For additional option in batch mode run following command:
knime.exe -consoleLog -noexit -nosplash -application org.knime.product.KNIME_BATCH_APPLICATION

Br,
Ivan

1 Like