Execution Error when scheduling a workflow

#1

This is my 1st time to experience this kind of issue in KNIME. Once i clicked the “Ok” button:

This error pop up:

I am not quite sure why this error is showing up only on this workflow that i created when i tried to schedule/automate them, When i tried to run the workflow “manually” it is successful no error or warning are popping up.

0 Likes

#2

Hi @rdaveligon10,

this error is typical for the situation, when a workflow that was saved in KNIME AP 4.0 is executed on a server that runs pre-4.0 executor. For example, on 4.8 server with 3.7 executor.

So could you please check versions of you Analytics Platform client as well as the Server and the corresponding executor.

Let me know, what will you find.

Best,
Mischa

2 Likes

#3

Thanks for your quick response. This workflow that i am currently working was created by our former colleague year’s a go. I was able to fix the issue by creating a new workflow in KNIME. and copy, paste all of the nodes and save it. I was able to Schedule the workflow without any issue. Thanks for your help really appreciative it :slight_smile:

2 Likes

#4

Hi,

good to know. Thanks for letting us know.
A suggestion for the future: if there will be a similar problem with another workflow, instead of copy-pasting nodes you can just open the problematic workflow in KNIME version that matches your Server and re=save it in that version. This should make it compatible.

Best regards,
Mischa

2 Likes