expert.mode=true being ignored

The -Dknime.expert.mode=true flag in my knime.ini file is being ignored, and I can't see any of the loop nodes. Nor can I see the flow variable tabs in any nodes already in workflows.

Where do I start troubleshooting?

KNIME 2.3.3
OSX 10.6.7
java 1.6.0_24
community nodes loaded

(the other) Simon

Have you edited the existing knime.ini file? See http://tech.knime.org/faq#q20 for its location on the Mac. Creating a new one directly in the KNIME directory does not work.

Dominik

Yes - this is an installation that was working only last week with loop nodes visible. Just stopped working recently...

 

(the other) Simon

Solved it.

A few lines down from the -Dknime.expert.mode=true line was another one: -Dknime.expert.mode=false.

Seems that the 2.3.3 update had added the second line to the end of the knime.ini file, but I didn't see it the first time I checked the file.

Once I removed the second line, everything is back to 'normal'.

 

(the other) Simon.

 

This is probably a silly question, but how do I enable expert mode in the SDK version of KNIME, i.e. the full eclipse environment. The only knime.ini I can find is in the non-SDK KNIME installation folder, which I never use. Eclipse.ini doesn't have an expert mode variable.

Of course my question assumes expert mode is switched off by default in the SDK environment. I can't see any looping nodes other than those in the four meta nodes, Feature Elimination, Iterate List of Files etc. That may be it, which I'll find disappointing, as I'm hoping there's a Iterate Over X Columns node hidden somewhere.

You need to add the magic line in the lauch configuration inside the IDE (Arguments -> VM arguments).

Sorry, was that an answer to my question? If so, where exactly do I find the list, command line, options, whatever for these arguments? Is it a panel in Eclipse or in a configuration file somewhere?

It's in the Eclipse Run Configurations, accessible via Run->Run Configurations.

I never did find where you were talking about. Under the Run menu I've only ever had a submenu "External Tools". It's missing all of the other options you usually have in Eclipse's Run menu.

Anyway, since I've just installed the KNIME SDK on a new machine, couldn't remember how I got developer mode working, googled it and found myself back here, it's probably worth me reporting that I just added "-Dknime.expert.mode=true" to the end of eclipse.ini.