extension installation failed - custom python node with dataprep


I tried to bundle an extension of custom node - and install it on another computer (in closed environment - no internet connection)

the installation failed in the other computer - i guess its because the dataprep package
I opened a ticket about failed installation with the command “conda install -c conda-forge dataprep”
and got an answer to activate my environment and install with: “pip install”.
it worked locally on my computer but when bundling the extension - its failed, I guess because its not through conda forge.

any solution?
or a way to add packages that installed by “pip install” to the bundling process?

I have no idea which ticket you mean. Nor did you write how and in which step the installation exactly failed. Or how you bundled it (for which version, with which parameters?). Did bundling work? Once you say that it you could not install it on the other computer, then you say the bundling step already failed.

Thus, I can only guess and give you the following section, where we describe how to insert pip packages.

Does that help?


Hello @steffen_KNIME

Thanks for the quick reply.

That’s the ticket I was talking about:

I’m working with 5.1 version, I bundled it with the command:
"build_python_extension.bat --include-packages --knime-version 5.1 " - the bundling work.
but after I installed it in the other computer (and restart knime) I get the error that dataperp not found:


Hi @hagay_finiti,

thanks for the details! Did you ever install that bundled extension on your original computer? Did it work there?

How does your environment.yml look like?

And did you have a look at the link I sent? I still think this might be the solution to your issue.


Hi @steffen_KNIME ,

I’m currently try to bundle by the link you attached with insertion of pip install,
I got connection error - I’m with stable WIFI connection, but I will try to connect with Ethernet cable for the bundle process:

my env file look like this now(changed after following your link):

name: my_python_env

  • knime
  • conda-forge
  • python=3.10
  • knime-extension=5.1
  • knime-python-base=5.1
  • pip:
    • dataprep


It changed the view to bullets, so I attached screenshot:


According to GitHub - sfu-db/dataprep: Open-source low code data preparation library in python. Collect, clean and visualization your data in python with a few lines of code.
dataprep also exists on conda-forge:
Dataprep :: Anaconda.org

did you try the following? (and you can format code here in the forum)

name: my_python_env
  - knime
  - conda-forge
  - python=3.10
  - knime-extension=5.1
  - knime-python-base=5.1
  - dataprep

Thank you @steffen_KNIME it worked with the pip install version.

I will try also with dataprep as conda dependency.

Thanks again

Hi @hagay_finiti,

I do not follow. What exactly did work now? That could be useful to others :slight_smile:


Hi @steffen_KNIME
sorry, this was the solution for me - change my environment file to this (with pip install):



1 Like

Ok so the connection error you mentioned earlier was really only a temporary issue?

Yes, it was problem of my network - I hope it wont confuse other people with my initial problem.
Thanks for your help,

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.