External SSH tool Auth fail


I'm trying to use the external ssh tool node to execute some shell commands on a remote Linux server. When clicking on "check connection", I get always the error "connection failed: Auth fail". All the parameters are correct (host, port:22, user name and password).

I appreciate any helpful answers/suggestions ! 



Please have a look in the log file if there is more information. Also try to execute the node and see if the error message is more comprehensive (also in the log file).

Thanks for helping. Here's the error message in knime.log

By the way, the node "SSH Connection" works fine.


2016-09-09 12:21:42,786 : ERROR : KNIME-Worker-4 : ExtSSHToolNodeModel : External SSH Tool : 3:24 : Job submission failed: Auth fail
2016-09-09 12:21:42,787 : DEBUG : KNIME-Worker-4 : External SSH Tool : External SSH Tool : 3:24 : reset
2016-09-09 12:21:42,787 : ERROR : KNIME-Worker-4 : External SSH Tool : External SSH Tool : 3:24 : Execute failed: Auth fail
2016-09-09 12:21:42,787 : DEBUG : KNIME-Worker-4 : External SSH Tool : External SSH Tool : 3:24 : Execute failed: Auth fail
com.jcraft.jsch.JSchException: Auth fail
    at com.jcraft.jsch.Session.connect(Session.java:512)
    at org.knime.ext.ssh.SSHUtil.getConnectedSession(SSHUtil.java:104)
    at org.knime.ext.ssh.node.ExtSSHToolNodeModel.execute(ExtSSHToolNodeModel.java:161)
    at org.knime.core.node.NodeModel.execute(NodeModel.java:732)
    at org.knime.core.node.NodeModel.executeModel(NodeModel.java:566)
    at org.knime.core.node.Node.invokeFullyNodeModelExecute(Node.java:1146)
    at org.knime.core.node.Node.execute(Node.java:933)
    at org.knime.core.node.workflow.NativeNodeContainer.performExecuteNode(NativeNodeContainer.java:556)
    at org.knime.core.node.exec.LocalNodeExecutionJob.mainExecute(LocalNodeExecutionJob.java:95)
    at org.knime.core.node.workflow.NodeExecutionJob.internalRun(NodeExecutionJob.java:179)
    at org.knime.core.node.workflow.NodeExecutionJob.run(NodeExecutionJob.java:110)
    at org.knime.core.util.ThreadUtils$RunnableWithContextImpl.runWithContext(ThreadUtils.java:328)
    at org.knime.core.util.ThreadUtils$RunnableWithContext.run(ThreadUtils.java:204)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    at org.knime.core.util.ThreadPool$MyFuture.run(ThreadPool.java:123)
    at org.knime.core.util.ThreadPool$Worker.run(ThreadPool.java:246)

I just tried here and both nodes work as expected if the correct login information is provided. The error message also doesn't indicate anything else then wrong login data. I have no idea what else could be wrong.

Thanks for the efforts. I'll try again and let you know if I find the problem ...


I have the same problem, also in my case ssh connection works, but not External SSH tool.

Any news about the solution?



I want to run a similar use case. I'm not able to find this "External SSH tool",where can I get it from ?

All I can see is "SSH Connection" node which does not allow me run commands. 


Thanks !

Mohammed Ayub

No worries. I got it on the Extensions site.

Was this issue solved?