External Tool (Labs) fails to write input table to file.

OS: Windows 10, 64 bit - KNiME 5.3.1

ERROR External Tool (Labs) 0:934      Execute failed: Can't access 'file:D:/KNIME/temp/Standardize_20180122_21605/output/port0.sdf'. (D:\KNIME\temp\Standardize_20180122_21605\output\port0.sdf (Das System kann die angegebene Datei nicht finden))


There is already an entry to this topic in the forum, but no solution. I am afraid that this might not be a KNIME problem, because the workflow worked perfectly until I updated Windows 10.

I also changed the temp directory. I don't see anything happening in the temp directory. Creating a diretory D:/KNIME/temp/Standardize_20180122_21606/output with a number higher, only leads to an error message ....20180122_21607.....

The Standardizer programs works fine outside KNIME.No license issue.

I also updated KNIME to 5.3.1. The same errror appeared.

Alex

 

Hi Alex,

This sounds like the output file was not created during execution. Can you please post the command line script you are using in the node?

Cheers,

Roland

StructureChecker.bat -c F:"\\Registration"\\structurechecker.xml -m fix -t separated -f sdf -o %outFile% %inFile% -d F:"\\Registration"\\discarded.sdf

The executable is in D:\\"Program Files\\ChemAxon\\StructureRepresentationToolkit"\\

The node works on Windows Server 2012, but not on Windows 10.

I also assume the file is not written because Windows 10 has some protection going on. I have set full executiion. read, write, delete to the temp directory for "jeder", everyone.

 

Hi Alex,

Can you please also post the relevant portion of knime.log when you tried to execute the node? And just to make sure I understand you correctly: Has the workflow worked on Windows 10 before the update, and is it still working now on Windows Server 2012?

Cheers,

Roland